Windows 10 nelilaskin näppiskielisyysbugi

Viestiketju alueella 'Ohjelmat, käyttöjärjestelmät ja ajurit' , aloittaja demu, 29.09.2016.

NOSTOJA MUROPAKETIN SISÄLLÖSTÄ
  1. demu

    Rekisteröitynyt:
    16.09.2002
    Viestejä:
    2 679
    Käytän joskus laiskuuttani WIN10:n palikkapuolen nelilaskinta (en jaksa avata exceliä).
    Ainakin itselläni on siinä sellainen ärsyttävä kieliasetusbugi, että kun painan kirjainnäppäimistössä miinus (-) -merkkiä, tuleekin samalla paikalla englanninkielisen näppäimistön merkki eli jakomerkki (/), plus-merkistä (+) tulee miinusmerkki, kertomerkistä (*) ei tule mitään, jakomerkistä (/) ei tule mitään.
    Ja laskuketjut menevät sitten aina ja uudestaan pieleen.
    Erillisen numeronäppäimistön operaatiomerkit tulevat oikein.

    Eikö MS:llä ole ollut hoksottimita tai rahaa korjata tällaista perusbugia?
    Vai bugaako vain oma winukkani?
     
  2. SuperD

    Rekisteröitynyt:
    08.02.2002
    Viestejä:
    4 596
    Jep, tuo on rikottu.
     
  3. Nik0-91

    Rekisteröitynyt:
    03.02.2009
    Viestejä:
    1 345
    Itsellä tuo toimii oikein, mutta desimaaleja ei voi erottaa pisteellä, vaan ne on erotettava pilkulla. Olen tottunut käyttämään pistettä ja se on toiminutkin aikaisemmissa Windowseissa ihan oikein.
     
  4. Hans Niskatuki Banned

    Rekisteröitynyt:
    13.03.2005
    Viestejä:
    2 166
    Tsekkasin juuri äsken silkasta mielenkiinnosta yhdellä koneistani. Eli englanninkielinen (en muista oliko jenkki- vai UK-versiona alunperin asennettu) wintoosa, FIN/FI kieli/kiippariasetuksina. Ja toimii juuri niinkuin pitääkin. Myöskin laskimessa on desimaalipiste käytössä desimaalierottimena, ei desimaalipilkku. Eli jenkkityyliin "yksi piste kaksi kolme neljä" (1.234), eikä Suomen malliin "yksi pilkku kaksi kolme neljä" (1,234).

    Joten ainaan oma toosani ei bugaa millään lailla tämän suhteen. En sitten tiedä vaikuttaako asiaan se että kokeilin tätä bt-näppiksellä jossa ei ole erillistä numeronäppäimistöä lainkaan.

    AP voisi tarkistaa vielä kieliasetuksistaan kaikki mahdolliset säädöt.
     
    Viimeksi muokattu: 01.10.2016
  5. Desgorr

    Rekisteröitynyt:
    11.10.2010
    Viestejä:
    3 207
    Täällä kanssa käytössä englanninkielinen (US versio) kymppi ja toimii kuten AP:lla. Kieliasetuksina (Mm. muotoiluasetukset ja näppis) on Suomi.

    Mikäs buildi teillä mahtaa olla kympistä ja versio laskimesta? Täällä on käytössä kympin buildi 14393.222. Tuon näkee painamalla WIN + R ja kirjoittamalla avautuvaan ikkunaan winver ja painamalla lopuksi OK.
    Ja laskimen versio on 10.1608.2213.0. Tämän näkee laskimen asetuksista.

    @Hans Niskatuki
    Onko sinulla kieliasetuksissa määritelty desimaalierottimeksi piste?
    Tuon voit tarkistaa: WIN + R -> intl.cpl -> OK -> Additional Settings...

    Edit:
    Läppärillä näyttäisi toimivan matemaattiset merkit normaalisti. Tuossa ei ole erillistä numeronäppistä.
     
    Viimeksi muokattu: 01.10.2016
  6. Sport_FIN

    Rekisteröitynyt:
    11.12.2015
    Viestejä:
    2 464
    Ihan normaalisti minulla tulee kannettavalla. Enkku versio ja FIN näppis.
     
  7. Hans Niskatuki Banned

    Rekisteröitynyt:
    13.03.2005
    Viestejä:
    2 166
    @Desgorr

    Kyseisen koneeni buildi näköjään 14393.187, Cumulative Update for Windows 10 Version 1607 for x64-based Systems (KB3194496) vielä roikkuu tuolla odottamassa asentamistaan...

    Laskimen versio: 10.1608.2213.0

    Region Additional Settingeissä Decimal Symbol on ,

    edit: Asensin tuon Cumulative Updaten ja nyt on toosa versiota .222. Ei kuitenkaan vaikuttanut laskimen toimintaan mitenkään. Toimii ihan buenosti edelleen.
     
    Viimeksi muokattu: 01.10.2016
  8. Hans Niskatuki Banned

    Rekisteröitynyt:
    13.03.2005
    Viestejä:
    2 166
    Kokeilin myös numeronäppäimistöllä varustellulla näppiksellä. Hyvin toimi laskin. Havaintoni mukaan siis erillisen numeronäppiksen puuttuminen tai läsnäolo ei vaikuta asiaan.
     
  9. julppu

    Rekisteröitynyt:
    11.03.2008
    Viestejä:
    421
    Itsellä työkoneessa sama ongelma. Olen huomannut, että kun tarpeeksi availee ja sulkee laskinta niin näppäimistön asettelu muuttuu ja normaalit */+- -merkit toimivat. Omalla kotikoneellani taas laskin toimii normaalisti. Melko ärsyttävä bugi, kun pitäisi kiireesti jotakin laskea.
     
  10. Desgorr

    Rekisteröitynyt:
    11.10.2010
    Viestejä:
    3 207
    Kieltämättä aika mystinen tuo laskimen toiminta. Nyt meinaan täälläkin toimii normaalisti myös näppispuolen matemaattiset merkit. Aiemmin ei tosiaan toiminut.

    Erikoista, että laskimessa kuitenkin toimii piste. Tuli meinaan itse testattua vaihtaa tuota desimaalierotinta ja tämä muutos näkyi myös laskimessa.
     

Jaa tämä sivu

Alibi
Anna
Deko
Dome
Erä
Hymy
Kaksplus
Kippari
Kotilääkäri
Kotiliesi
Koululainen
Ruoka.fi
Parnasso
Seura
Suomen Kuvalehti
TM Rakennusmaailma
Tekniikan Maailma
Vauhdin Maailma
Golfpiste
Vene
Nettiauto
Ampparit
Plaza
Muropaketti