Webbisivun välkähdys valkoiseksi latautuessa

Viestiketju alueella 'Ohjelmointi' , aloittaja Moguli, 09.10.2017.

  1. Moguli

    Rekisteröitynyt:
    28.06.2001
    Viestejä:
    581
    Ongelmana on, että webbisivun lataantuessa se latautuu melkein kokonaan ja sen jälkeen välkähtää kokonaan tyhjäksi/valkoiseksi noin 1-3 sekunniksi, jonka jälkeen sivu sitten näkyy oikein. En ole itse sivustoa rakentanut ja mukana on paljon linkkejä Javascript-koodeihin. Onko jotain keinoa, jolla sivun voisi kokeeksi ladata vaiheittain ja nähdä, että minkä koodin kohdalla ruutu muuttuu valkoiseksi? Tai onko muita ideoita, jolla ongelman syytä voisi lähteä selvittämään?
     
  2. Phoenx

    Rekisteröitynyt:
    20.11.2007
    Viestejä:
    216
  3. Moguli

    Rekisteröitynyt:
    28.06.2001
    Viestejä:
    581
    Okei, tuo kyllä on tuttu html:n ja css:n tsekkauksesta, mutten ole sitä js-tsekkauksissa käyttänyt, kun en ole niitä hommia tehnyt. Pitää tutustua tarkemmin.
     
  4. Phoenx

    Rekisteröitynyt:
    20.11.2007
    Viestejä:
    216
    Jep. Tuon avulla voit ainakin debugata tuota JS:ää asettamalla sinne tänne breakpointeja. Vaikea sanoa mistä tuo sivun valkoiseksi muuttuminen johtuu, mutta veikkaisin kovasti jotakin JS-kikkaretta.
     
  5. Paapaa

    Rekisteröitynyt:
    14.04.2005
    Viestejä:
    10 932
    Tohditko laittaa linkkiä sivuun?
     

Jaa tämä sivu

Alibi
Anna
Deko
Dome
Erä
Hymy
Kaksplus
Kippari
Kotilääkäri
Kotiliesi
Koululainen
Ruoka.fi
Parnasso
Seura
Suomen Kuvalehti
TM Rakennusmaailma
Tekniikan Maailma
Vauhdin Maailma
Golfpiste
Vene
Nettiauto
Ampparit
Plaza
Muropaketti