Low voltage cutoff 555-piirillä. Miksi ei toimi??

Viestiketju alueella 'Elektroniikka ja HW-modifiointi' , aloittaja NusNus, 07.12.2014.

NOSTOJA MUROPAKETIN SISÄLLÖSTÄ
  1. NusNus

    Rekisteröitynyt:
    16.03.2002
    Viestejä:
    229
    Minulla olisi tarvetta tehdä 2s lipo-akulle piiri joka katkaisee sähköt kun jännite tippuu tietylle tasolle.

    TÄMÄN piirin tein mutta ei toimi!?! Simuloin piirin tietokoneella, katselin netistä ohjeita ja vinkkejä mutta oikeassa elämässä piiri ei vaan toimi.

    Piirin tarkoitus on siis olla low voltage cutoff hystereesillä. Laskin vastukset niin, että cut-off tapahtuu 6,4V jännitteellä ja piiri avautuu taas kun jännite on yli 6,6V.

    Missä siis voisi olla vika? Olen säätänyt vastukset kohdilleen mutta ulostulo on aina 1, välittämättä mihin suuntaan jännitelähteen nuppia pyöritän.

    Käyttämäni komponentit (katso schemaa linkissä):

    - NE555P
    - C1 = 0,47 uF
    - C2 = 220 uF
    - R1 = R3 = 10 kOhm
    - R4 = 10k (jolloin akun jännitteen ollessa 6,6 V, alkaa ulostulo taas johtamaan)
    - R2 = 3,5 k Ohm (virta katkeaa kun akun jännite <= 6,4 V)
    - L7805CV regu
    - Ulostulossa (pin 3) ledi ja sen vastus
     
  2. aape ronkka

    Rekisteröitynyt:
    23.10.2013
    Viestejä:
    162
    Itse on tullut joskus tehneeksi ihan hölmöjä kytkentävirheitä kun on rakennellut, jos sinulla tässä sama vika?

    Mittaa jännitteen jalkojen 1-2 ja 1-6 väliltä (onko jännitteenjakovastukset vahingossa väärissä 555:sen jaloissa)
    Tuleeko jalkojen 1-8 väliin +5volttia (onko regulaattorikytkentä kunnossa)

    Onko 555 ehjä?
     
  3. StiNgeRWeb

    Rekisteröitynyt:
    07.09.2001
    Viestejä:
    3 034
    Yhtenä ongelmana varmaan on, että tuo regu vaatii noin 7V jännitteen toimiakseen oikein eli 6,6V tai varsinkin 6,4V on liian vähän joten 555:n käyttöjännite ei ole sitä mitä pitää.
     
  4. NusNus

    Rekisteröitynyt:
    16.03.2002
    Viestejä:
    229
    Olen tehnyt kaksi samanlaista piiriä ja kummassakin on sama vika. Se tässä ihmetyttää. 555 pitäisi olla ehjä. Kytkentä ei ole koskaan toiminut, ja alussa kun testailin niin mitään outoa ei tapahtunut jotta 555 olisi hajonnut.

    Jännitteet koipien välissä kun syöttöjännite 8V:
    1-2: 0V
    1-6: 0V
    1-8: 5V

    Onko 5-pinnin Control kondensaattorin oltava joku tietyn mallinen? Minulla on tällä hetkellä elektrolyytti.

    Hyvä pointti Stingerweb regulaattorista. Se täytyy muuttaa muuksi kunhan saan ensin piirin toimimaan jollain jännitteellä.
     
  5. LM2

    Rekisteröitynyt:
    29.11.2010
    Viestejä:
    1 089
  6. aape ronkka

    Rekisteröitynyt:
    23.10.2013
    Viestejä:
    162
    tuon takia ei sitten toimi.. Sinulla on kytkennässäsi kaiketi joku vika noissa jännitteenjakovastus jutussa.

    jalkaan 2 pitäisi tulla 8 voltin käyttöjännitteellä 4 volttia ja jalkaan kuusi 2.8 volttia (jos nyt oikein laskin)

    Jos rakentelet verolevylle niin kuin tuossa rakennusohjeessa, tutki huolellisesti että olet katkaissut kaikki foliot oikeista kohdista niin kuin pitää ja jos olet 3.5mm poraterällä tehnyt katkokset noihin verolevyn folioihin niin käy ne kaikki läpi ettei ole jäänyt kuparia mihinkään. Tarkasta yleismittarilla vielä ettei tinasiltoja ole oikosulkemassa foliota toisiinsa.

    Ja mittaa vastukset R1-R4 kytkennästä mitä ohmeja ne näyttää?
     
  7. AirMan

    Rekisteröitynyt:
    26.02.2001
    Viestejä:
    1 616
    Oletko kokeillut kytkentää niin, että regulaattorille on oma käyttöjännite ja vastusjaoille oma säädettävä, niin varmistut siitä, ettei jännite tipahda regulaattorille liian alas? Entä oletko kokeillut C1 tilalla hieman pienempää muovikondensaattoria? Hattuvakiolla vaikka 100nF. Elektrolyytti saattaa vuotaa sen verran, ettei kytkentä toimi. Ja yleismittari voi myös kuormittaa vastusjakoja sen verran, ettei sieltä saa todellisia lukemia ulos. Onhan vastukset varmasti mittaamalla tarkistettu, ettei ole tullut vahingossa laitettua jotain tarkkuusvastuksia kymmenen kertaa suuremmalla tai pienemmällä resistanssilla? Sama juttu ledin ja etuvastuksen kanssa. Toimivatko suoraan käyttöjännitteestä? Onko piirin reset-pinni varmasti irti?
     
  8. NusNus

    Rekisteröitynyt:
    16.03.2002
    Viestejä:
    229
    Sain piirin toimimaan!!

    Kokosin sen kolmannen kerran ja alustana oli "breadboard". Pistin triggriksi 8V ja thresholdiksi 9V ja toimii kuin unelma vaikka controllin ja maan välissä on elektrolyytti.

    Kun arvoiksi valitaan 6,4V ja 6,6V niin homma menee kinkkiseksi. Piiri toimii ainoastaan silloin, jos jännitteen laskee sysäyksellä U > 6,6V -> U < 6,4V. Eli taitaa monen tietämykseen perustuva regulaattorin rajoitus tulla vastaan. Tässä ei ole väliä jos käyttää muovikonkkaa tai elektrolyyttiä.

    Piiri ei siis toimi suoraan siellä missä haluan. Ehkä regulaattorin voisi korvata zenerillä.

    Mutta kiitos kaikille avusta!
     
  9. velleri

    Rekisteröitynyt:
    27.02.2005
    Viestejä:
    14 247
    Aika kapea tuo haluamasi välikkö; 0,2 volttia. Jos niin tarkkaan lopputulokseen 555:llä pääsee, niin päälle/pois -napsutus on melkoista, jos akulla on vähänkään suurempi kuorma. Ehkä joku 6 ja 6,8 volttia voisi olla järkevämpi alue.

    Se vielä tuli mieleen, että miksi et käytä valmista suojapiiriä? Jos itse pitää saada tehdä, niin sen toki ymmärrän.
     
  10. NusNus

    Rekisteröitynyt:
    16.03.2002
    Viestejä:
    229
    Tässä on nimenomaan kyse itse tekemisestä :).

    Olet oikeassa jännitteen kanssa. Ongelma on vaan siinä, että Lipo-kennojen pienin sallittu jännite on 3,3 V / kenno eli 6,6 V kahdella kennolla. Täyteen ladattuna jännite on 4,2V eli 8,2V kahdella kennolla.

    Rajan voisi kyllä laittaa vaikk 6,8 V ja 8V. Siinä olisi jo 1,2 V erotus.
     
  11. velleri

    Rekisteröitynyt:
    27.02.2005
    Viestejä:
    14 247
    Jos purkaa vain 3,3 volttiin asti, jää kapasiteettia reilusti käyttämättä. Samaan malliin nuo voi purkaa 2,5 volttiin, kuin perus li-ion -kennotkin. Toki se on lopullinen raja, eikä akkua tule jättää pidemmäksi ajaksi niin loppuun asti purettuna. Kennojen mahdollinen epäbalanssi tulee ottaa huomioon äärimmilleen purettaessa tai ladattaesssa.
     
  12. NusNus

    Rekisteröitynyt:
    16.03.2002
    Viestejä:
    229

    En välttämättä viitsisi alkaa kikkailemaan näiden kanssa. En ole koskaan nähnyt räjähtävää Lipoa, mutta youtuubi kertoo ettei se ole kivaa. Mielummin jätän pelivaraa tai varmistan valmistajalta akkujen todellisen toimintarajan.

    Nopea google kertoo seuraavaa:

    "Just as with other kinds of lithium-ion cells, the voltage of a LiPo cell depends on its chemistry and varies from about 2.7-3.0 V (discharged) to about 4.20-4.35 V (fully charged), for cells based on lithium-metal-oxides (such as LiCoO2), and around 1.8-2.0 V (discharged) to 3.6-3.8 V"
     
  13. velleri

    Rekisteröitynyt:
    27.02.2005
    Viestejä:
    14 247
    Jos räjähtämistä pelkää, niin kannattaa olla ylilataamatta. Kahden kennon sarjalle 8,4 volttia on maksimi. Jos kennot ovat hivenenkin epäbalanssissa, niin toinen ylilatautuu kys. jännitteellä.

    Muovipussikennot ovat ihan päteviä ilmaisemaan "mielialansa"; jos kenno on hivenenkin pullistunut, ei sitä kannata enää edes yrittää ladata.
     

Jaa tämä sivu

Alibi
Anna
Deko
Dome
Erä
Hymy
Kaksplus
Kippari
Kotilääkäri
Kotiliesi
Koululainen
Ruoka.fi
Parnasso
Seura
Suomen Kuvalehti
TM Rakennusmaailma
Tekniikan Maailma
Vauhdin Maailma
Golfpiste
Vene
Nettiauto
Ampparit
Plaza
Muropaketti