Excel tai LibreOffice apua kaivataan

Viestiketju alueella 'Ohjelmointi' , aloittaja ipuli, 23.11.2017.

  1. ipuli

    Rekisteröitynyt:
    23.11.2017
    Viestejä:
    1
    Moi,
    Ongelma olisi seuraavanlainen, tarvitsisin jonkinlaisen kaavan millä saan Excelin tai LibreOfficen vertaamaan kahta kellon aikaa ja vertauksen perusteella lisäämään päivämäärän joka on joko sama tai seuraava päivä kuin soluissa A2-A50

    Käytännössä siis minulla on taulukko jossa on A2-A50 sarakkeissa pvm muotoa (Ma 1.11.2017) B2-B50 sarakkeissa klo 1 (08:00) C2-C50 sarakkeissa klo 2 (19:00) sarkkeisiin D2-D50 haluan automaattisesti päivämäärän (1.11.2017 tai Ma 1.11.2017)
    Jos A2 on Ma 1.11.2017, B2 on 08:00, C2 on 19:00, niin D2 pitäisi olla 1.11.2017 (tai Ma 1.11.2017)
    Jos A3 on Ti 2.11.2017, B3 on 23:00, C3 on 02:00, niin D3 pitäisi olla 3.11.2017 (tai Ke 3.11.2017)

    Tosiaan A sarakkeen pvm on juokseva mutta voi hypätä välissä esim. A3 3.11 ja A4 8.11 jne. B ja C sarakkeiden kellonajat vaihtuvat myös välillä 00:00-23:59...

    Toivottavasti joku ymmärsi tästä sepustuksesta mikä on ongelmana ja osaa auttaa, käytännössä olen ihan toivoton Excelin ja LibreOfficen kanssa tällaisissa tilanteissa... Eikä ole väliä kumpaan ohjelmaan saisin ratkaisun tähän ongelmaan...
     
  2. AntZuWeb

    Rekisteröitynyt:
    08.05.2012
    Viestejä:
    237
    Excelissä ensin muotoilet A- ja D-sarakkeet päivämääriksi ja B- ja C-sarakkeet kellonajoiksi.
    D1-soluun kaava suomenkielisessä Excelissä =JOS(B1>C1;A1+1;A1), englanninkielisessä =IF(B1>C1;A1+1;A1)
    Sitten vaan kopioit tuon kaavan D-sarakkeessa alaspäin, jolloin esim. solussa D5 kaava on =JOS(B5>C5;A5+1;A5)

    Sama toimii myös LibreOfficessa.
     

Jaa tämä sivu

Alibi
Anna
Deko
Dome
Erä
Hymy
Kaksplus
Kippari
Kotilääkäri
Kotiliesi
Koululainen
Ruoka.fi
Parnasso
Seura
Suomen Kuvalehti
TM Rakennusmaailma
Tekniikan Maailma
Vauhdin Maailma
Golfpiste
Vene
Nettiauto
Ampparit
Plaza
Muropaketti