1. Bugiraportit ja palaute XenForo-MuroBBS:stä tähän viestiketjuun

    Tuliko vastaan englantia tai huonoa suomea, raportoi tähän viestiketjuun

Oletusyhdyskäytävä

Viestiketju alueella 'Ongelmat' , aloittaja Nigel^, 05.09.2006.

  1. Nigel^

    Rekisteröitynyt:
    19.12.2004
    Viestejä:
    427
    Haluan asettaa manuaalisesti lähiverkko-ip:t ja muut sälät. Ongelmani on se, että minulla ei ole mitään hajua mitä pistän oletusyhdyskäytävä kohtaan.

    Tiedän, että toiseen koneeseeni laitan IP:ksi 192.168.0.1 ja toiseen 192.168.0.2 ja aliverkon peitteeksi molempiin 255.255.255.0. Ongelma piilee tässä oletusyhdyskäytävässä, mitä en tiedä.

    DNS-palvelimeen liittyvä täppä luultavasti kannattaa pitää tuossa: "Hae DNS-palvelinosoite automaattisesti" -kohdassa.

    Apuja kiitos.

    EDIT: Huomasinkin, että DNS-palvelinkin on määriteltävä manuaalisesti jos nuo IP:t ja muut roskat määrittää manuaalisesti.
     
  2. konTomi

    Rekisteröitynyt:
    21.05.2003
    Viestejä:
    105
    Jos lähiverkkosi menee jonkin purkin, kuten adsl-modeemin kautta, laita oletusyhdyskäytäväksi boksin ip, samoin dns:ään.

    Niin, ja jos ei mene minkään boksin kautta, laitat vain saman yhdyskäytävän kaikkiin koneisiin, esimerkiksi 192.168.0.10.
     
  3. Nigel^

    Rekisteröitynyt:
    19.12.2004
    Viestejä:
    427
    Nyt kun vähän aikaa sähläilin sain taas netin kuntoon. Verkko ei enää kylläkään pelitä. Lähiverkkoyhteyden tila on "Vajaa tai puuttuva liitettävyys."

    Elikkä siis. Laitoin tämän koneen IP:ksi 192.168.0.1 ja tämä on se kone, missä sisäinen adsl-modeemi sijaitsee. Aliverkon peitteeksi laitoin 255.255.255.0. Oletusyhdyskäytäväksi laitoin tuon edellämainitun 192.168.0.10 ja DNS:ään 192.168.0.5. Laitoin samat asetuksen myös toiseen koneeseen, mutta IP:ksi tietysti 192.168.0.2 ja netti ei tämän jälkeen toiminut kummassakaan koneessa.

    Netti ei pelitä toisessa koneessa, vaikka laittaisin täpät kohtiin "Hae IP-osoite automaattisesti" ja "Hae DNS-palvelinosoite automaattisesti" molemmissa koneissa. Tässä koneessa netti toimii, jos laittaa automaattiset asetukset.

    Jos laitan manuaalisesti kaikki osoitteet molempiin koneisiin, niin netti ei toimi kummassakaan koneessa, mutta jos laitan tähän koneeeseen vain IP:n ja aliverkon peitteen, niin netti toimii, mutta ei vieläkään toisessa koneessa.

    Voisiko joku siis kertoa kumpaankin koneeseen sopivat osoitteet ja neuvoa nyt kädestä pitäen, että tässä saisi jotain aikaankin.

    Koneet ovat siis yhdessä toisiinsa verkkokortista verkkokorttiin ristiinkytketyllä cat5e-kaapelilla.


    Ihmetyttää vain, miksei netti toisessa koneessa toimi automaattisilla asetuksilla vaikka ennen tätä manuaalista kokeilua se pelitti mainiosti.
     
  4. Kenzy

    Rekisteröitynyt:
    21.12.2002
    Viestejä:
    4 648
    Noniin, taas sama stoori:
    Koneessa 1
    Käynnistä - asetukset - ohjauspaneeli - verkkoyhteydet
    Hiiren 2. napilla sitä ADSL-sovitinta -> Ominaisuudet
    Lisäasetukset-välilehti -> Ruksi kohtaan "Salli muiden käyttää tätä yhteyttä jne..."
    Sitten ookoota.
    Hiiren 2. napilla sitä lähiverkkoon yhdistävää sovitinta -> Ominaisuudet
    TCP/IP -> Ominaisuudet
    IP: 192.168.5.1
    Aliverkon peite: 255.255.255.0
    Oletusyhdyskäytävä: Tyhjä
    Ensisijainen DNS: Tyhjä
    Sitten Käynnistä - Asetukset - Ohjauspaneeli - Järjestelmä - Tietokoneen nimi - Muuta:
    Työryhmä: OMAVERKKO
    SAMMUTA KONE 1

    Kakkoskoneessa:
    Käynnistä-asetukset-ohjauspaneeli-verkkoyhteydet:
    Hiiren 2. namikalla Ominaisuudet
    TCP/IP -> Ominaisuudet
    IP: 192.168.5.2
    Aliverkon peite: 255.255.255.0
    Oletusyhdyskäytävä: 192.168.5.1
    Ensisijainen DNS: 192.168.5.1
    Sitten Järjestelmä - tietokoneen nimi - muuta
    Työryhmä: OMAVERKKO
    SAMMUTA KONE 2

    KÄYNNISTÄ KONE 1, odota, että työpöytä on täysin latautunut, KÄYNNISTÄ KONE 2. Varmista myös, että ADSL-sovitin hakee kaikki ip:t sun muut automaattisesti.[signature]- Lopeta totuuden etsiminen ja asetu aloillesi hyvään fantasiaan -[/signature]
     
  5. Nigel^

    Rekisteröitynyt:
    19.12.2004
    Viestejä:
    427
    Nyt molempien koneiden verkkosovittimen tila on "yhdistetty", mutta siltikään netti ei pelaa toisella koneellani. Cmd.exe:ssä ping-komentoa käyttämällä tulee vain: "Pyystö aikakatkaistiin." Pingaus ei siis toimi kummallakaan koneella.

    Tuntuu aika mystiseltä tämä ongelma.

    Mitenköhän on, kun minulla on tässä adsl-sovittimen omaavassa koneessa vain yksi verkkokortti, mutta verkkoyhteyksissä näkyy niitä kaksi. Toinen on Realtek RTL8139 ja toinen joku 1394-verkkosovitin. Aina olen käyttänyt tuota Realtekkiä.

    Mitäs tuo siltaus tarkoittaa? Minulla on soneran yhteys ja eikös se ole joku bridged-systeemi?
     
  6. Toe

    Rekisteröitynyt:
    20.07.2000
    Viestejä:
    801
    Nyt menee asiat niin sekaisin ja päällekkäin, että otetaanpas pieni aikalisä.

    Realtek RTL8139 on verkkokortti, 1394-verkkosovitin on koneessasi oleva firewire-liitin, jonka läpi sopivalla kaapelilla yhdistettynä windows osaa ajaa verkkoliikennettä toiseen samalla tavalla konffattuun koneeseen, siitä ei tarvitse nyt välittää.

    Ensimmäiseksi sinun on saatava ADSL-yhteytesi toimimaan. Melko varmaan palveluntarjoajasi on lähettänyt sinulle yksityiskohtaiset ohjeet siitä miten ADSL-modeemi konfiguroidaan oikein. ADSL-modeemin manuskasta löytyy varmasti oikeat säädettävät kohteet, jos yhteydentarjoajaltasi ei ole tullut ohjeita suoraan sen nimenomaisen kortin konffaamiseen. Kun olet saanut ADSL-kortillisen koneen toimimaan, voit alkaa miettiä toisen koneen yhteyttä. Avaa komentoriviprompti ja katso "ipconfig /all"-komennolla millaisen IP-osoitteen ADSL-kortti on saanut operaattorilta. Se voi hyvin olla näitä privaatti-ip osoitteita, eli 192.168.x.x, 10.x.x.x tai 172.(16-31).x.x joita käytetään kun Internettiin päin on ns. NAT, eli osoitteenmuutos käytössä. Ota ylös nimipalvelimien(DNS) osoitteet. Mitkä tahansa ADSL-modeemin IP-osoitteen numerosarjan kolme ensimmäistä numeroa ovatkin, et saa käyttää sitä osoiteavaruutta omien koneidesi välissä, siis verkkokorttien osoitteina. Yleisesti ottaen oletusyhdyskäytävä löytyy useimmiten siitä .1 tai .254 osoitteesta, eli esim. esim. 192.168.0.1. Lähiverkon maskina C-luokan maski, eli 255.255.255.0 on kotiverkossa ihan ok.

    Seuraavaksi kannattaa saattaa kuntoon kotiverkko. Testaamisessa voi Windowssin ja kolmansien osapuolien palomuuriohjelmat haittana. Ehdotankin että irroitat ADSL-modeemin johdon verkosta ja käännät kaikki mahdolliset palomuurit koneista pois päältä. Jos olo on rohkea ja tapana on hypätä irtosuhteissa ilman kortsua, voi toki sen ADSL:n jättää kiinnikkin, mutta virukset ja troijalaiset tarttuvat Windowssiin paljon helpommin kuin HIV heppiin...

    Olettaen että tuo 192.168.0.0-verkko ei ollut käytössä ADSL-modeemissa, laita ADSL-modeemin koneen verkkokortille osoite 192.168.0.1, maski 255.255.255.0. Oletusyhdyskäytävä sinulla on ADSL-modeemissa, joten sitä ei tähän tarvitse laittaa. Toiseen koneeseen laitat verkkokortille osoitteen 192.168.0.2, maskin 255.255.255.0, oletusyhdyskäytäväksi 192.168.0.1 ja nimipalvelimeksi sen osoitteen/osoitteet jotka ADSL-koneen ipconfig /all-komennolla otit aikaisemmin talteen. Nyt voit koittaa pingailla koneiden välillä, Internet-yhteys ei varmasti vielä toimi kakkoskoneesta.

    Tässä kohdin kannattaa laittaa palomuurit takaisin päälle ja ADSL takaisin kiinni, Windowssin yhteydenjakowizardi muistaakseni tekee tarpeeksi reikiä koneen palomuuriin yhteyden toimintaan saattamiseksi. Kolmansien osapuolien palomuureista on paha sanoa muuta kuin että jos niitä löytyy, lue valmistajan manuaalit tai on-line tuet.

    Tuolta http://www.practicallynetworked.com/sharing/xp_ics/ löytyy yksityiskohtainen ohje verkon jakamisen päälle laittamiseen.
    [signature]Asus A8R32-MVP, Opty175, CM Hyper 6+, 2GB OCZ Gold, SATAII, Gf7900GT, Audigy 2
    P4 HT@3GHz surffikone, Mini-itx P4 2,66GHz HTPC, P3 serveri, Duron palomuuri...[/signature]
     
  7. Nigel^

    Rekisteröitynyt:
    19.12.2004
    Viestejä:
    427
    Ongelma ratkaistu. Veikkaan, että vika oli palomuurissa ja väärässä DNS-palvelinosoitteessa.

    Nyt kuitenkin ilmeni toinen ongelma. Miksei Verkkoympäristö näy toista verkossa olevaa konetta. Siis kun menen verkkoympäristöön ja painan "Näytä työryhmän koneet", niin siellä näkyy vain se kone, jolla sillä hetkellä olen. Molempien koneiden työryhmänä on MSHOME.
     
  8. Toe

    Rekisteröitynyt:
    20.07.2000
    Viestejä:
    801
    Palomuurissa estetty Windowsin tiedostonjako tai koneessa ei ole yhtään hakemistoa jaettuna? Oletko koittanut administrativiista C-aseman jakoa? Eli mappaat verkkoaseman tyyliin \\toisenkoneennimi\c$ ?

    [signature]Asus A8R32-MVP, Opty175, CM Hyper 6+, 2GB OCZ Gold, SATAII, Gf7900GT, Audigy 2
    P4 HT@3GHz surffikone, Mini-itx P4 2,66GHz HTPC, P3 serveri, Duron palomuuri...[/signature]
     
  9. Nigel^

    Rekisteröitynyt:
    19.12.2004
    Viestejä:
    427
    Pääsen toisen koneen jaettuihin tiedostoihin, kun kirjoitan omassa tietokoneessa \\koneennimi\, mutta miksei koneet siltikään näy työryhmässä?
     
  10. Kenzy

    Rekisteröitynyt:
    21.12.2002
    Viestejä:
    4 648
    Se vaan aina joskus menee niin, monesti koneiden uudelleenkäynnistys auttaa asiassa, ja vielä useammin auttaa, että se nettiä jakava kone on päällä ennen kakkoskoneen käynnstämistä. Jos tiedostojenjako pelaa muuten, siis tuolla suoralla komennolla, on tuo vaan joku Windowsin bugi. Ihan normaalia, ainakin itselläni tullut vastaan useita kertoja.
    [signature]- Lopeta totuuden etsiminen ja asetu aloillesi hyvään fantasiaan -[/signature]
     
  11. Nigel^

    Rekisteröitynyt:
    19.12.2004
    Viestejä:
    427
    Jostain syystä en pysty enää selaamaan toisen koneeni jaettuja tiedostoja tällä koneella, missä modeemi sijaitsee. Valittaa käyttöoikeuksista. Toisinpäin homma kyllä pelaa. Palomuurista ei voi olla kiinni, koska molemmissa koneissa on samat asetukset ja sama palomuuro.
     
  12. Kenzy

    Rekisteröitynyt:
    21.12.2002
    Viestejä:
    4 648
    Vieras-tili pitäisi varmaankin olla käytössä, eikä olisi pahitteeksi, jos molemmilla koneilla olisi täysin samanniminen käyttäjä. Ei tarvitse olla se, jolla konetta käytät, mutta olemassa olisi hyvä olla. Itse en ole koskaan törmännyt mihinkään käyttöoikeusjuttuihin, mutta joillakin joilla niitä on ollut, on nuo em. keinot auttanut.
    [signature]- Lopeta totuuden etsiminen ja asetu aloillesi hyvään fantasiaan -[/signature]
     
  13. Nigel^

    Rekisteröitynyt:
    19.12.2004
    Viestejä:
    427
    Kummassakaan koneessa ei ole muita käyttäjätilejä, kuin järjestelmänvalvoja, joten mitään kirjautumishässäkkää ei ole. Eli siis koneen käynnistyessä kone menee suoraan windowsiin.
     
  14. THT

    Rekisteröitynyt:
    21.05.2003
    Viestejä:
    260
    Lisäksi sama salasana. Ja joskus ongelma tuntui ratkenneen jopa niin ettei toisella koneella saanut olla logannut se samanniminen.
    [signature]Kesän ahkera laiskottelu alkaa olla ohi ja edessä on ahkeraa laiskottelua seuraavat ei niin kesäiset kuukaudet. Arvioisin sitä aikaa, näin etukäteen, rasittavana mutta tarpeellisena askeleena kohti parempia aikoja. Kyllä se siitä.[/signature]
     
  15. Nigel^

    Rekisteröitynyt:
    19.12.2004
    Viestejä:
    427
    Jotenkin tuntuu, että microsoftin pojat ei ole ajatelleet tätä asiaa ihan järkevästi.
     
  16. Kenzy

    Rekisteröitynyt:
    21.12.2002
    Viestejä:
    4 648
    Eihän ne ole miettineet mitään asiaa ihan järkevästi, tuo nyt ei ole mikään yllätys sinänsä :P
    [signature]- Lopeta totuuden etsiminen ja asetu aloillesi hyvään fantasiaan -[/signature]
     

Jaa tämä sivu