FFDShow Säätöopas v2.0 Täydellinen uudelleenkirjoitus. Muokattu 8.3.2009.

Viestiketju alueella 'Ohjelmat, käyttöjärjestelmät ja ajurit' , aloittaja Hot Metal, 02.12.2004.

  1. Hot Metal

    Rekisteröitynyt:
    03.04.2001
    Viestejä:
    206
    Vistaa kun en käytä niin en voi kuin mutuilla asiasta, mutta:
    Onhan Codecs-välilehdeltä kaikki säädetty kuntoon?

    [signature]Athlon 64 3000+@4100+, Radeon X1900 XT, 1 GB PC-3200[/signature]
     
  2. Kaotika Moderaattori

    Rekisteröitynyt:
    02.11.2000
    Viestejä:
    43 285
    Mikä mediasoitin?
    Käsittääkseni FFDSHOW ei koske millään muotoa WMV HD videoihin.
    itsellä on käytössä ffdshow_rev971_20070226_clsid_sse_icl9 paketti, hyvin pelaa WMP:n kanssa Vista x64:lla
    Sen onko FFDSHOW käytössä näkee ihan sillä että tuleeko systrayhyn FFDSHOWn kuvakkeita videon pyöriessä
    [signature]take the universe and grind it down to the finest powder and sieve it through the finest sieve and then show me one atom of justice, one molecule of mercy. and yet you act as if there is some ideal order in the world, as if there is some...some rightness in the universe by which it may be judged. - - koitko vääryyttä moderoidessani? palautetta osoitteeseen cryofnight@pp.nic.fi[/signature]
     
  3. gore

    Rekisteröitynyt:
    19.02.2002
    Viestejä:
    440
    OK. Poistan aikaisemman ffdshown ja testaan tuota. Mediasoittimena Vistan Media Player.

    EDIT: Nyt video näkyy oikein Admin-tunnuksella, mutta normaali käyttäjällä video näkyy väärinpäin. Nyt tuli kuvakkeet myös oikein alalaitaan. Ah mulla olikin jääny asetuksista kuvan kääntö päälle aikaisemman ffdshown johdosta (poisto ei ilmeisesti poistakaan asetuksia). Nyt toimii oikein. Aikaisemmissa ffdshowssa ei ollut asetuksilla mitään vaikutusta nyt on.

    Oiskohan nuo ongelmat johtunut siitä, että asensin ffdshown admin tunnuksella ja sitten testasin normi käyttäjällä. Nyt testasin ensin admin käyttäjällä ja sen jälkeen normi käyttäjällä. Nooh pääasia, että toimii :) Kiitos avusta!
    [signature]Fujitsu-Siemens AMILO Xi 1554 (T7200 @ 2GHz, 2GB @ 533MHz, 2 x 160GB @ RAID 0, ATI Mobility Radeon X1900, 17" WUXGA 1920 x 1200, Vista Ultimate x64 + 2 x Samsung T166 HD501LJ (500GB, 16MB, SATA II)[/signature]
     
  4. ad-amb

    Rekisteröitynyt:
    25.11.2002
    Viestejä:
    325
    Hmmm, sen verran hämmennän soppaa - itsellä tosiaan tuo "ffdshow_rev1006_20070307"käytössä ja sellainen kumma juttu tässä Vistassa, että WinAmp näyttää videon ok, mutta BSPlayerilla taas (jonka pitäisi näyttää tekstit myös) niin tekstitys ja äänet pelaa, mutta kuvaa ei näy --> mustaa ruutua/ikkunaa pukkaa. En ole vielä kokeillut aiempaa revikkaa, mutta outoa että sitten taas WinAmpilla toimii (joskaan tekstitystä en saa WinAmpilla aikaan). Muilla vastaavaa?
    [signature]MAXBient
    1.|ASUS P5B Deluxe|E6600@8x360mhz|2048MB PC6400@450mhz/4,4,3,8|X1950 PRO@590/725|w/Air
    2.|SERVERI - MSI K7N2 Delta-ILSR|XP3000+@11x210mhz|1024MB PC3200|GF2 32MB|w/Air
    3.|ABIT NF7-S2G|XP2200+@13,5x155mhz|738MB PC3200|TI-4400 VIVO@288/599|w/Air
    --> 4.|SHUTTLE XPC SN45G v3|XP2600+|512MB PC2700|R9600 PRO@400/223|w/Air
    [/signature]
     
  5. Kaotika Moderaattori

    Rekisteröitynyt:
    02.11.2000
    Viestejä:
    43 285
    tuo on jo monta kertaa kerrottu täällä, pitää vaihdaa BSPlayerin output modea directdraw surfaceksi tms, helpommalla pääsee ku käyttää WMP:ta ;)
    [signature]take the universe and grind it down to the finest powder and sieve it through the finest sieve and then show me one atom of justice, one molecule of mercy. and yet you act as if there is some ideal order in the world, as if there is some...some rightness in the universe by which it may be judged. - - koitko vääryyttä moderoidessani? palautetta osoitteeseen cryofnight@pp.nic.fi[/signature]
     
  6. Tatikkan

    Rekisteröitynyt:
    16.02.2007
    Viestejä:
    1 504
    Itellä on ViPlay Beta 3 tarjonnut parhaimman kuvanlaadun.
     
  7. Kaotika Moderaattori

    Rekisteröitynyt:
    02.11.2000
    Viestejä:
    43 285
    Tuskinpa se itse player siihen kuvanlaatuun vaikuttaa yhtään millään tapaa, paitsi kenties vaihtamalla eri output moodiin (esm. vmr:t, overlayt jne), mutta noita voi useimmissa soittimissa vaihtaa itsekseenkin
    [signature]take the universe and grind it down to the finest powder and sieve it through the finest sieve and then show me one atom of justice, one molecule of mercy. and yet you act as if there is some ideal order in the world, as if there is some...some rightness in the universe by which it may be judged. - - koitko vääryyttä moderoidessani? palautetta osoitteeseen cryofnight@pp.nic.fi[/signature]
     
  8. Tatikkan

    Rekisteröitynyt:
    16.02.2007
    Viestejä:
    1 504
    Juu en ole sen kummemmin tutustunut säätöihin, kun itse tykkään että ohjelmat on mahdollisimman yksinkertaisia. Kaikki turhat härpäkkeet pois.
     
  9. Hewi

    Rekisteröitynyt:
    11.03.2004
    Viestejä:
    7 435
    Silti sanoit että viplay on tarjonnut parhaimman kuvanlaadun, mutta toisaalta kerrot että et kummemmin ole tutustunut säätöihin, kun tykkäät yksinkertaisesta. Mahtavaa..tällaiset arviot kertovat juurikin siitä kuinka paljon kannattaa netissä katsella muiden mielipiteitä. Mutulla on hjyvä mennä.

    Turhista härpäkkeistä puheenollen suosittelen kokeilemaan MPUI+mplayer settiä. Siinä ei paljoa mitään ole.
     
  10. Tatikkan

    Rekisteröitynyt:
    16.02.2007
    Viestejä:
    1 504
    No vakioasetuksilla siis paras kuvanlaatu. Itse asetukset teen FFDShow:ssa.

    Että tunkase se oma mielipiteesikin sinne ruskeaan reikään.
     
  11. Hewi

    Rekisteröitynyt:
    11.03.2004
    Viestejä:
    7 435
    Mitäh??

    ffdshow on se joka sen kuvan työstää! Aivan sama millä soittimella niitä sinne ffdshowlle lykkäät. Ainoa asia joka vaikuttaa on toki se jo puhuttu overlay.
     
  12. Hot Metal

    Rekisteröitynyt:
    03.04.2001
    Viestejä:
    206
    Noniin, lopettakaas topicin täyttö turhanpäiväisellä kinastelulla tai siirtäkää se ainakin jonnekkin muualle.
    Asiaa raapaisten itse soitto-ohjelmat eivät käytännössä vaikuta kuvanlaatuun elleivät ne käytä jotain omia filttereitään.
    [signature]Athlon 64 3000+@4100+, Radeon X1900 XT, 1 GB PC-3200[/signature]
     
  13. Corex

    Rekisteröitynyt:
    14.07.2001
    Viestejä:
    3 431
    Argh, tässä monta tuntia yrittänyt kikkailla että sais noi filtterit toimimaan DVD toistossa Media Player Classicin kanssa. Ei onnistu sitten millään. Joskus asensin toiselle koneelle ffdshow + media player classicin ja sain kyllä DVD toiston toimiin mutta en todellakaan muista miten. Ison tappelun takana se oli, se on jäänyt mieleen...

    Sain toki filtterit toimimaan tavallisten divx ja xvid pätkien kanssa mutta en DVD toistossa. Koneelle ei ole asennettu mitään kaupallista DVD soitinta, ainoastaan Media Player Classic 6.4.9.0 ja sit vanhempi BS player.

    Filtterit tulee käyttöön ainoastaan jos laitan FFDSHOW:n Codecs kohtasta MPEG2 = libavcodec. Media Playerista pitää myös tehdä seuraavaa:View => Options => Internal Filters => Ruksi pois MPEG-2 Video:sta.

    Tällöin vaan kuva menee pilalle mutta filtterit toimii. Reso nousee jne.

    Edit: Filtterit pärähtää päälle myös jos laitan MPEG2 = libmpeg2 mutta kuva suttaantuu myös näin.

    DVD toimii ilman kuvan rikkoontumista ainoastaan MPEG2 = disabled mutta tällöin filtterit ei toimi.

    Mites muut on saanut tuon toimiin?

    Edit: Sain toimimaan kuin taikaiskusta. Asensin TV kortin mukana tulleen MPEG koodekin, pistin FFDSHOW:sta MPEG2 = Disabled ja tadaa, filtterit toimii media playerissa ja kuva ei häröile.

    Gspot väittää ettei codekkeja ole asennettu MPEG:lle, mielenkiintoista...Kuiten jos avaan DVD:ltä VOB:in gspotilla niin siellä render testissä tulee tällänen litannia:

    Cyberlink DTV video decoder => ffdshow video decoder => Video renderer

    Eihän tuosta nyt ota mitään selvää mitä mikin käyttää :|


    [signature]-Tyhmä kerskuu hevosellaan, hullu vaimollaan ja lahjaton lapsillaan
    -Siloaivojen viihdettä[/signature]
     
  14. Bowtie81

    Rekisteröitynyt:
    30.10.2002
    Viestejä:
    6 097
    itse asensin käyttiksen uudelleen ja sen jälkeen uusin ffdshow ei toiminut, kuva oli mustavalkonen ja vähän jotain lilan ja vihreen laikkuja. Asensin koemielessä sitten gom playerin ja tämä ei vaadi erillisiä kodekkeja, hyvin on kaikki videot toimineet ja soitinkin on aika hyvän oloinen, verrattuna mediaplayeriin.
    [signature]Weppisivut
    MYYTÄVÄNÄ, prossua, emoa, usbkiintistä...[/signature]
     
  15. Tatikkan

    Rekisteröitynyt:
    16.02.2007
    Viestejä:
    1 504
    Ohoh, ihan näppärä vehjes tää GomPlayer.
     
  16. HuGGyBeaR

    Rekisteröitynyt:
    17.10.2000
    Viestejä:
    1 695
    Iskin nuo oppaan asetukset tohon filtteriin. Nyt kuitenkin joillain pätkillä tulee noita "pakkausjälkiä", eli näkyy sellasia laatikoita. Mitäs asetusta pitää alkaa muuttamaan, että nämä saa poistettua?
    [signature]opteron 165 | Abit kn8-sli | 2048 ram | inno3d 7900gt | Antec Neo HE 430W | Kaikki vakiona toistaseksi...
    reseptiarkisto[/signature]
     
  17. Hot Metal

    Rekisteröitynyt:
    03.04.2001
    Viestejä:
    206
    Oletan että nämä pakkausroskat näkyivät ennenkin, jos tälläisiä mössöjä tulee videoihin missä niitä ei ennen ole ollut asiat ovat pahemman kerran pielessä.

    Itse asiaan:
    Postprocessing-lehti säätelee nimenomaan pakkausroskien mössäystä.
    Sieltä voi laittaa processing strengthiä suuremmalle arvolle tai jos kyseessä on ns. "laatikkomerestä" johon normaali käsittely ei pure niin asetuksen voi vaihtaa SPP Deblocking:lle joka takuulla poistaa laatikot mutta on todella raskas.

    Huomionarvoista on myös se että "automatic quality control" tiputtaa postprocessingin tasoa tai ottaa sen pois kokonaan jos prosessori menee tappiin (mikä on hyvinkin mahdollista tai jopa todennäköistä oppaan asetuksilla, ainakin jos FPS doubler on päällä).
    Eli ennenkuin alkaa postprocessingin asetuksia muuttamaan, kannattaa videota katsellessa avata postprocessing-lehti ja tarkkailla reaaliajassa miten se toimii.
    [signature]Athlon 64 3000+@4100+, Radeon X1900 XT, 1 GB PC-3200[/signature]
     
  18. Miikka M

    Rekisteröitynyt:
    25.11.2005
    Viestejä:
    5 320
    En nyt jaksais lähtee kaahaa koko ketjua läpi. Tein ekan viestin ohjeiden mukaisesti ja sit kuvat meni tummaks ettei mitään näe. Voisko joku auttaa?

    Itsellä on uusin CCCP asennettuna. Soittimina CMP ja MCP.
    [signature]O.C.T.O.P.U.S
    Oikkuileva Countrykitaristi Tuittupäinen Opossuminkesyttäjä ja Puoleensavetävän Urhoollinen Shamaani[/signature]
     
  19. Hot Metal

    Rekisteröitynyt:
    03.04.2001
    Viestejä:
    206
    Heh, eipä tuosta paljoa muuta voi sanoa kuin että poista kaikki asennetut codecit/codecpackit sekä ffdshow.
    Sitten asennat uudestaan pelkästään FFDShown ja kokeilet.
    Jos sitten ei toimi niin vika on jossain muualla.

    [signature]Athlon 64 3000+@4100+, Radeon X1900 XT, 1 GB PC-3200[/signature]
     
  20. gore

    Rekisteröitynyt:
    19.02.2002
    Viestejä:
    440
    Saakos ffdshow:lla pyörimään seuraavat HD-formaatit vai tarvitaanko, joku lisäosa ja jos tarvitaan niin mikä (ei mielellään kauhea codec-pakettijööti :):

    .mkv
    .ts
    .mp4

    Käyttiksenä Vista Ultimate x64 ja soittimena Windows Media Player 11
    [signature]Fujitsu-Siemens AMILO Xi 1554 (T7200 @ 2GHz, 2GB @ 533MHz, 2 x 160GB @ RAID 0, ATI Mobility Radeon X1900, 17" WUXGA 1920 x 1200, Vista Ultimate x64 + 2 x Samsung T166 HD501LJ (500GB, 16MB, SATA II)[/signature]
     
  21. Miikka M

    Rekisteröitynyt:
    25.11.2005
    Viestejä:
    5 320
    Ei auttanu. Kertokaas miten saan resetoituu ffdshow:n kaikki asetukset..
    [signature]O.C.T.O.P.U.S
    Oikkuileva Countrykitaristi Tuittupäinen Opossuminkesyttäjä ja Puoleensavetävän Urhoollinen Shamaani[/signature]
     
  22. Hot Metal

    Rekisteröitynyt:
    03.04.2001
    Viestejä:
    206
    Öh...sanoin siis tossa ylhäällä että poista kaikki codecit SEKÄ ffdshow.
    Asetukset pitäisi resetoitua kun ohjelman poistaa ja asentaa uudelleen.

    Mutta melkein jokaisella välilehdellä on "Reset" nappi joka yllättäen resetoi asetukset.
    [signature]Athlon 64 3000+@4100+, Radeon X1900 XT, 1 GB PC-3200[/signature]
     
  23. Miikka M

    Rekisteröitynyt:
    25.11.2005
    Viestejä:
    5 320
    Niin tein.

    Ei mitään enää. Ratkaisin jo. Olin sörkkiny väärää asetusta.. Jotai joka säätää noita väri juttuja kai.. DCT kohta tais olla.
    [signature]O.C.T.O.P.U.S
    Oikkuileva Countrykitaristi Tuittupäinen Opossuminkesyttäjä ja Puoleensavetävän Urhoollinen Shamaani[/signature]
     
  24. Hot Metal

    Rekisteröitynyt:
    03.04.2001
    Viestejä:
    206
    Noh, hyvä että ratkesi. DCT metsässä tosiaan voi aiheuttaa kaikkea mielenkiintoista. ;)
    [signature]Athlon 64 3000+@4100+, Radeon X1900 XT, 1 GB PC-3200[/signature]
     
  25. Miikka M

    Rekisteröitynyt:
    25.11.2005
    Viestejä:
    5 320
    Mut joo.. Nyt kyl jotkut videot nykii aika pirusti.. Täytyy vielä säätää. Ei taida AMD X2 3800+ oikein riittää potku?
    [signature]O.C.T.O.P.U.S
    Oikkuileva Countrykitaristi Tuittupäinen Opossuminkesyttäjä ja Puoleensavetävän Urhoollinen Shamaani[/signature]
     

Jaa tämä sivu